]> git.ekhem.eu.org Git - guix.git/commitdiff
Preserve `guix home` and `etags` instructions in a Makefile.
authorJakub Czajka <jakub@ekhem.eu.org>
Fri, 3 Jun 2022 17:52:49 +0000 (19:52 +0200)
committerJakub Czajka <jczajka@google.com>
Sun, 24 Dec 2023 18:53:07 +0000 (19:53 +0100)
Makefile [new file with mode: 0644]
README

diff --git a/Makefile b/Makefile
new file mode 100644 (file)
index 0000000..76cc090
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,15 @@
+# Copyright (c) 2022 Jakub Czajka <jakub@ekhem.eu.org>
+# License: GPL-3.0 or later.
+
+guix-profile := ~/.guix-home/profile
+guix-store := /gnu/store
+guix-version := $(shell guix show guix | sed -n '/^version/s/^.*: //gp')
+
+home:
+       GUIX_PACKAGE_PATH=`pwd` guix home reconfigure home.scm
+       . $(guix-profile)/etc/profile
+
+tags:
+       find $(guix-store) -wholename "*guix-$(guix-version)*.scm" -or \
+               -wholename "*guix-module-union*.scm" | xargs etags
+       find `pwd` -name "*.scm" | xargs etags --append
diff --git a/README b/README
index 99d1f31fc7ff1085a3705fa319d04da92b9eb918..f0c139b97c3d2d3bf59ddfa2b4822c50cfe8006d 100644 (file)
--- a/README
+++ b/README
@@ -2,7 +2,8 @@ guix
 ====
 
 System and home directory configuration for the GNU Guix operating system. It
-installs programs and their configuration files (dotfiles).
+installs programs and their configuration files (dotfiles). See Makefile for
+installation instructions.
 
 Files
 -----